summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 6cbd8ecbd1..f1400a842a 100644
--- a/configure.in
+++ b/configure.in
@@ -221,8 +221,6 @@ if test "$GCC" = yes; then
else
linker_flag=
fi
-CFLAGS="${CFLAGS} `eval echo $cflags`"
-CXXFLAGS="${CXXFLAGS} `eval echo $cxxflags`"
RUBY_PROG_GNU_LD
RUBY_CPPOUTFILE
@@ -335,6 +333,9 @@ if test "$GCC:${warnflags+set}:no" = yes::no; then
warnflags="-Wall -Wno-unused-parameter -Wno-parentheses ${warnflags+$warnflags }-Wpointer-arith -Wwrite-strings"
fi
+CFLAGS="${CFLAGS} `eval echo $cflags`"
+CXXFLAGS="${CXXFLAGS} `eval echo $cxxflags`"
+
dnl check for large file stuff
mv confdefs.h confdefs1.h
: > confdefs.h