summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-03-13 09:58:05 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-03-13 09:58:05 +0000
commitd202fd4f97f6f871887cb9c92cf3cc3b39175434 (patch)
tree328615da5d2f79e66e921234dbf360c84cd3169e /configure.in
parentbc34d16363712a1b0f536b6996fcf7685b9a8582 (diff)
* configure.in (CFLAGS, CXXFLAGS): moved after warnflags.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@22928 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 6cbd8ecbd1..f1400a842a 100644
--- a/configure.in
+++ b/configure.in
@@ -221,8 +221,6 @@ if test "$GCC" = yes; then
else
linker_flag=
fi
-CFLAGS="${CFLAGS} `eval echo $cflags`"
-CXXFLAGS="${CXXFLAGS} `eval echo $cxxflags`"
RUBY_PROG_GNU_LD
RUBY_CPPOUTFILE
@@ -335,6 +333,9 @@ if test "$GCC:${warnflags+set}:no" = yes::no; then
warnflags="-Wall -Wno-unused-parameter -Wno-parentheses ${warnflags+$warnflags }-Wpointer-arith -Wwrite-strings"
fi
+CFLAGS="${CFLAGS} `eval echo $cflags`"
+CXXFLAGS="${CXXFLAGS} `eval echo $cxxflags`"
+
dnl check for large file stuff
mv confdefs.h confdefs1.h
: > confdefs.h