summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoryugui <yugui@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-01-17 10:40:51 +0000
committeryugui <yugui@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-01-17 10:40:51 +0000
commitfe011304e7cddc0080ca59cb0df0bbe21bf203bb (patch)
treec3d1dcf9c392db9b59c94946387a5751c50f8db0 /configure.in
parentcfa14a55540e0548cb4d9ecb7de09e2b74c4cd87 (diff)
* configure.in (VCSUP): fixed the cases for git-svn or git.
* win32/Makefile.sub (VCSUP): ditto. * Makefile.in (up): `cd' is necessary for git and git-svn. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@21630 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 77c00343a5..264903ea3f 100644
--- a/configure.in
+++ b/configure.in
@@ -2172,10 +2172,10 @@ AC_CONFIG_FILES(Makefile, [{
VCSUP='$(VCS) up $(SVNUPOPTIONS)'
elif test -d "$srcdir/.git/svn"; then
VCS='git svn'
- VCSUP='$(VCS) up $(SVNUPOPTIONS)'
+ VCSUP='$(VCS) rebase $(GITSVNREBASEOPTIONS)'
elif test -d "$srcdir/.git"; then
VCS='git'
- VCSUP='$(VCS) up $(GITUPOPTIONS)'
+ VCSUP='$(VCS) pull $(GITPULLOPTIONS)'
else
VCS='echo cannot'
VCSUP='$(VCS)'