summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-08-13 09:40:12 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-08-13 09:40:12 +0000
commitc29206461f2d0c610eafed50e6658202aeb050ec (patch)
tree3aed387e7b722d1a222afc5f4fa703a3c20b5a5e /configure.in
parentc9e7e6617ba2f76f0ff8b69501825018b21f9520 (diff)
* configure.in (RUBY_CHECK_SIZEOF): set cross_compiling to yes
only when AC_COMPUTE_INT, and inverted the arguments. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@24529 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 77b4a53c02..1f807049fb 100644
--- a/configure.in
+++ b/configure.in
@@ -189,7 +189,7 @@ if test ${target_archs+set}; then
target=`echo $target | sed "s/^$target_cpu-/universal-/"`
target_alias=`echo $target_alias | sed "s/^$target_cpu-/universal-/"`
target_cpu=universal
- cross_compiling=yes
+ real_cross_compiling=$cross_compiling
else
target=`echo $target | sed "s/^$target_cpu-/${target_archs}-/"`
target_alias=`echo $target_alias | sed "s/^$target_cpu-/${target_archs}-/"`
@@ -381,8 +381,10 @@ esac
AC_CHECK_TYPES([long long, off_t])
AC_CACHE_CHECK([char bit], [rb_cv_char_bit],
- [AC_COMPUTE_INT([CHAR_BIT], [rb_cv_char_bit],
- [AC_INCLUDES_DEFAULT([@%:@include <limits.h>])], [rb_cv_char_bit=8])])
+ [cross_compiling=yes
+ AC_COMPUTE_INT([rb_cv_char_bit], [CHAR_BIT],
+ [AC_INCLUDES_DEFAULT([@%:@include <limits.h>])], [rb_cv_char_bit=8])
+ cross_compiling=$real_cross_compiling])
dnl RUBY_CHECK_SIZEOF [typename], [maybe same size types], [macros], [include]
AC_DEFUN([RUBY_CHECK_SIZEOF],
@@ -427,7 +429,8 @@ static ac__type_sizeof_ *rbcv_ptr;
m4_ifval([$2][$3], [case "${AS_TR_SH(ac_cv_sizeof_$1)}" in
when([SIZEOF_*]);;
when(*)])
- AC_COMPUTE_INT(AS_TR_CPP(SIZEOF_$1), [t], [AC_INCLUDES_DEFAULT([$4])]
+ cross_compiling=yes
+ AC_COMPUTE_INT([t], AS_TR_CPP(SIZEOF_$1), [AC_INCLUDES_DEFAULT([$4])]
[${cond+$cond
@%:@else}
$rbcv_var
@@ -435,6 +438,7 @@ ${cond+@%:@endif}
@%:@ifndef AS_TR_CPP(SIZEOF_$1)
@%:@define AS_TR_CPP(SIZEOF_$1) 0
@%:@endif], [t=0])
+ cross_compiling=$real_cross_compiling
if test ${t-0} != 0; then
AS_TR_SH(ac_cv_sizeof_$1)="${AS_TR_SH(ac_cv_sizeof_$1)+${AS_TR_SH(ac_cv_sizeof_$1)-} }${t}"
fi