summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-08-13 09:22:12 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-08-13 09:22:12 +0000
commitc9e7e6617ba2f76f0ff8b69501825018b21f9520 (patch)
treedde42b6756c906dc5d360b7b60f24154fe960aec /configure.in
parent72072e6343bf0f12b4f6ca5a4f953b46fe2db709 (diff)
* configure.in (RUBY_CHECK_SIZEOF): use AC_COMPUTE_INT instead of
_AC_COMPUTE_INT_COMPILE with cross compiling, since its arguments have been changed at autoconf 2.64. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@24528 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index e8e919e828..77b4a53c02 100644
--- a/configure.in
+++ b/configure.in
@@ -189,6 +189,7 @@ if test ${target_archs+set}; then
target=`echo $target | sed "s/^$target_cpu-/universal-/"`
target_alias=`echo $target_alias | sed "s/^$target_cpu-/universal-/"`
target_cpu=universal
+ cross_compiling=yes
else
target=`echo $target | sed "s/^$target_cpu-/${target_archs}-/"`
target_alias=`echo $target_alias | sed "s/^$target_cpu-/${target_archs}-/"`
@@ -380,7 +381,7 @@ esac
AC_CHECK_TYPES([long long, off_t])
AC_CACHE_CHECK([char bit], [rb_cv_char_bit],
- [_AC_COMPUTE_INT_COMPILE([CHAR_BIT], [rb_cv_char_bit],
+ [AC_COMPUTE_INT([CHAR_BIT], [rb_cv_char_bit],
[AC_INCLUDES_DEFAULT([@%:@include <limits.h>])], [rb_cv_char_bit=8])])
dnl RUBY_CHECK_SIZEOF [typename], [maybe same size types], [macros], [include]
@@ -426,14 +427,14 @@ static ac__type_sizeof_ *rbcv_ptr;
m4_ifval([$2][$3], [case "${AS_TR_SH(ac_cv_sizeof_$1)}" in
when([SIZEOF_*]);;
when(*)])
- _AC_COMPUTE_INT_COMPILE(AS_TR_CPP(SIZEOF_$1), [t], [AC_INCLUDES_DEFAULT([$4])]
+ AC_COMPUTE_INT(AS_TR_CPP(SIZEOF_$1), [t], [AC_INCLUDES_DEFAULT([$4])]
[${cond+$cond
@%:@else}
$rbcv_var
${cond+@%:@endif}
@%:@ifndef AS_TR_CPP(SIZEOF_$1)
@%:@define AS_TR_CPP(SIZEOF_$1) 0
-@%:@endif], [unset t])
+@%:@endif], [t=0])
if test ${t-0} != 0; then
AS_TR_SH(ac_cv_sizeof_$1)="${AS_TR_SH(ac_cv_sizeof_$1)+${AS_TR_SH(ac_cv_sizeof_$1)-} }${t}"
fi