summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-12-02 04:02:20 +0000
committernaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-12-02 04:02:20 +0000
commit9b69817ac0bfdd5b63ff7ac67905a4c1251b9496 (patch)
tree83dcdfad7014c8f6a52827616d873f3a3e06caa4 /configure.in
parent6ec1902a2d0f83484cd3b0d046f29f8b1a0eb435 (diff)
Revert r33926 "* configure.in: use $linker_flag for LDFLAGS option which is not"
This breaks build process of Linux and FreeBSD. It may depend the version of gcc. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@33927 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index eed4697687..e685913c33 100644
--- a/configure.in
+++ b/configure.in
@@ -2346,9 +2346,9 @@ AS_CASE("$enable_shared", [yes], [
[freebsd*|dragonfly*], [],
[
if test "$GCC" = yes; then
- RUBY_TRY_LDFLAGS([${linker_flag}--no-undefined], [no_undefined=yes], [no_undefined=no])
+ RUBY_TRY_LDFLAGS([-Wl,--no-undefined], [no_undefined=yes], [no_undefined=no])
if test "no_undefined" = yes; then
- RUBY_APPEND_OPTION(EXTLDFLAGS, [${linker_flag}--no-undefined])
+ RUBY_APPEND_OPTION(EXTLDFLAGS, [-Wl,--no-undefined])
fi
fi
])
@@ -2441,7 +2441,7 @@ AS_CASE("$enable_shared", [yes], [
# enable PIE if possible
if test "$GCC" = yes; then
RUBY_TRY_CFLAGS(-fPIE, [RUBY_APPEND_OPTION(XCFLAGS, -fPIE)
- RUBY_APPEND_OPTION(XLDFLAGS, ${linker_flag}-pie)])
+ RUBY_APPEND_OPTION(XLDFLAGS, -pie)])
fi
])
if test "$enable_rpath" = yes; then