summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-12-02 02:30:38 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-12-02 02:30:38 +0000
commit6ec1902a2d0f83484cd3b0d046f29f8b1a0eb435 (patch)
treed2ed1344e3b4924882ba41ad04f7ccd0a68f872d /configure.in
parent12697d5078436faca0a96273e19fb02d6f49e01d (diff)
* configure.in: use $linker_flag for LDFLAGS option which is not
limited to particular platforms. [ruby-core:41438] [Bug#5697] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@33926 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index e685913c33..eed4697687 100644
--- a/configure.in
+++ b/configure.in
@@ -2346,9 +2346,9 @@ AS_CASE("$enable_shared", [yes], [
[freebsd*|dragonfly*], [],
[
if test "$GCC" = yes; then
- RUBY_TRY_LDFLAGS([-Wl,--no-undefined], [no_undefined=yes], [no_undefined=no])
+ RUBY_TRY_LDFLAGS([${linker_flag}--no-undefined], [no_undefined=yes], [no_undefined=no])
if test "no_undefined" = yes; then
- RUBY_APPEND_OPTION(EXTLDFLAGS, [-Wl,--no-undefined])
+ RUBY_APPEND_OPTION(EXTLDFLAGS, [${linker_flag}--no-undefined])
fi
fi
])
@@ -2441,7 +2441,7 @@ AS_CASE("$enable_shared", [yes], [
# enable PIE if possible
if test "$GCC" = yes; then
RUBY_TRY_CFLAGS(-fPIE, [RUBY_APPEND_OPTION(XCFLAGS, -fPIE)
- RUBY_APPEND_OPTION(XLDFLAGS, -pie)])
+ RUBY_APPEND_OPTION(XLDFLAGS, ${linker_flag}-pie)])
fi
])
if test "$enable_rpath" = yes; then