summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-12-02 06:18:21 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-12-02 06:18:21 +0000
commit55cae8834019d9112e31cad097ecb3beff5e244c (patch)
treefa5b658c656b4dd1edb424b5d182c0e9e7739384 /configure.in
parent9b69817ac0bfdd5b63ff7ac67905a4c1251b9496 (diff)
* configure.in: use $linker_flag for LDFLAGS option which is not
limited to particular platforms. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@33928 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index e685913c33..5678e6da00 100644
--- a/configure.in
+++ b/configure.in
@@ -2346,9 +2346,9 @@ AS_CASE("$enable_shared", [yes], [
[freebsd*|dragonfly*], [],
[
if test "$GCC" = yes; then
- RUBY_TRY_LDFLAGS([-Wl,--no-undefined], [no_undefined=yes], [no_undefined=no])
+ RUBY_TRY_LDFLAGS([${linker_flag}--no-undefined], [no_undefined=yes], [no_undefined=no])
if test "no_undefined" = yes; then
- RUBY_APPEND_OPTION(EXTLDFLAGS, [-Wl,--no-undefined])
+ RUBY_APPEND_OPTION(EXTLDFLAGS, [${linker_flag}--no-undefined])
fi
fi
])