summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2015-12-22 13:56:34 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2015-12-22 13:56:34 +0000
commit52c3b2eb2afc9b2587dc1530331b9667dfab442b (patch)
treed2821dcc18be4687a2ca5adc542092e21e454e71
parent4eac2e833cf1518f676a468bec6ad161062431bc (diff)
io-console.gemspec: BSD-2-Clause
* ext/io/console/io-console.gemspec: change the license to BSD-2-Clause since "ruby" is no longer valid license as gem. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@53245 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
-rw-r--r--NEWS3
-rw-r--r--ext/io/console/io-console.gemspec2
2 files changed, 3 insertions, 2 deletions
diff --git a/NEWS b/NEWS
index e33f968..396b83b 100644
--- a/NEWS
+++ b/NEWS
@@ -258,7 +258,8 @@ with all sufficient information, see the ChangeLog file.
* Fiddle::Function#call releases the GVL. [Feature #11607]
* io-console
- * Update to io-console 0.4.4
+ * Update to io-console 0.4.4, and change the license to BSD 2-clause
+ "Simplified" License.
* lib/base64.rb
* Base64.urlsafe_encode64: added a "padding" option to suppress
diff --git a/ext/io/console/io-console.gemspec b/ext/io/console/io-console.gemspec
index 6482d4c..f77de85 100644
--- a/ext/io/console/io-console.gemspec
+++ b/ext/io/console/io-console.gemspec
@@ -15,7 +15,7 @@ Gem::Specification.new do |s|
s.require_path = %[lib]
s.files = %w[console.c extconf.rb lib/console/size.rb]
s.extensions = %w[extconf.rb]
- s.licenses = "ruby"
+ s.license = "BSD-2-Clause"
s.cert_chain = %w[certs/nobu.pem]
s.signing_key = File.expand_path("~/.ssh/gem-private_key.pem") if $0 =~ /gem\z/
end