summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index be6bbd2129..1343697b5d 100644
--- a/configure.in
+++ b/configure.in
@@ -1606,6 +1606,23 @@ if test -z "$MANTYPE"; then
fi
AC_SUBST(MANTYPE)
+AC_ARG_WITH(baseruby,
+ [ --with-baseruby=RUBY use RUBY as baseruby; RUBY is the pathname of ruby],
+ [
+ case "$withval" in
+ *ruby*)
+ BASERUBY=$withval
+ ;;
+ *)
+ AC_MSG_ERROR(need ruby)
+ ;;
+ esac
+ ],
+ [
+ BASERUBY="ruby"
+ ])
+AC_SUBST(BASERUBY)
+
if test -f config.h && tr -d '\015' < confdefs.h | cmp -s config.h -; then
echo "config.h unchanged"
else