summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorusa <usa@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2007-01-23 06:41:22 +0000
committerusa <usa@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2007-01-23 06:41:22 +0000
commitb69642052686971d0694732ee02d742f11982deb (patch)
tree67ab16e42050bfcabecbbfa8be63132bbf2038c8 /configure.in
parent06720d45c74de5b0a000ebb04148623e4bb03fc2 (diff)
* Makefile.in, common.mk, configure.in, */{Makefile.sub, configure.bat,
setup.mak}: add --with-baseruby configure option. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@11559 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index be6bbd2129..1343697b5d 100644
--- a/configure.in
+++ b/configure.in
@@ -1606,6 +1606,23 @@ if test -z "$MANTYPE"; then
fi
AC_SUBST(MANTYPE)
+AC_ARG_WITH(baseruby,
+ [ --with-baseruby=RUBY use RUBY as baseruby; RUBY is the pathname of ruby],
+ [
+ case "$withval" in
+ *ruby*)
+ BASERUBY=$withval
+ ;;
+ *)
+ AC_MSG_ERROR(need ruby)
+ ;;
+ esac
+ ],
+ [
+ BASERUBY="ruby"
+ ])
+AC_SUBST(BASERUBY)
+
if test -f config.h && tr -d '\015' < confdefs.h | cmp -s config.h -; then
echo "config.h unchanged"
else