summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1d3f328ee8..387d82cc04 100644
--- a/configure.in
+++ b/configure.in
@@ -392,6 +392,13 @@ RUBY_NACL
AS_CASE(["$host_os:$build_os"],
[darwin*:darwin*], [
AC_CHECK_TOOLS(CC, [gcc-4.2 clang gcc cc])
+ # Following Apple deployed clang are broken
+ # clang version 1.0 (http://llvm.org/svn/llvm-project/cfe/tags/Apple/clang-23 exported)
+ # Apple clang version 2.0 (tags/Apple/clang-137) (based on LLVM 2.9svn)
+ # Apple clang version 2.1 (tags/Apple/clang-163.7.1) (based on LLVM 3.0svn)
+ if [ $CC = "clang" ] && $CC --version | grep 'clang version [12 ]\.' ; then
+ AC_MSG_ERROR(clang version 3.0 or later is required)])
+ fi
])
if test x"${build}" != x"${host}"; then
AC_CHECK_TOOL(CC, gcc)