summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 4a0af908e6..f7cc86dfca 100644
--- a/configure.in
+++ b/configure.in
@@ -586,8 +586,11 @@ if test "$with_dln_a_out" != yes; then
LDFLAGS="-Wl,-E"
rb_cv_dlopen=yes;;
solaris*) if test "$GCC" = yes; then
- LDSHARED='$(CC) -Wl,-G -shared'
- `$CC --print-prog-name=ld` -v 2>&1 | grep "GNU ld" > /dev/null && LDFLAGS="-Wl,-E"
+ LDSHARED='$(CC) -Wl,-G'
+ if `$CC --print-prog-name=ld` -v 2>&1 | grep "GNU ld" > /dev/null; then
+ LDFLAGS="-Wl,-E"
+ LDSHARED="$LDSHARED -shared"
+ fi
else
LDSHARED='ld -G'
fi