summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoreban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2002-01-25 09:00:50 +0000
committereban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2002-01-25 09:00:50 +0000
commita0bf3b3bb98c04ca25c8b3bf670b2d4edc52e81a (patch)
treeb0964791d4743ab708492092be97e716af757f7a /configure.in
parentf547c1150cf0cb9fe2477e6aeb4ff7b724fc44c7 (diff)
* configure.in (solaris): add '-shared' only for GNU ld.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@2017 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 4a0af908e6..f7cc86dfca 100644
--- a/configure.in
+++ b/configure.in
@@ -586,8 +586,11 @@ if test "$with_dln_a_out" != yes; then
LDFLAGS="-Wl,-E"
rb_cv_dlopen=yes;;
solaris*) if test "$GCC" = yes; then
- LDSHARED='$(CC) -Wl,-G -shared'
- `$CC --print-prog-name=ld` -v 2>&1 | grep "GNU ld" > /dev/null && LDFLAGS="-Wl,-E"
+ LDSHARED='$(CC) -Wl,-G'
+ if `$CC --print-prog-name=ld` -v 2>&1 | grep "GNU ld" > /dev/null; then
+ LDFLAGS="-Wl,-E"
+ LDSHARED="$LDSHARED -shared"
+ fi
else
LDSHARED='ld -G'
fi