summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 29c5c126eb..b278942689 100644
--- a/configure.in
+++ b/configure.in
@@ -1805,7 +1805,9 @@ if test x"$enable_pthread" = xyes; then
[c], [],
[root], [],
[c_r], [MAINLIBS="-pthread $MAINLIBS"],
- [LIBS="-l$pthread_lib $LIBS"])
+ [AS_CASE(["$target_os"],
+ [openbsd*], [LIBS="-pthread $LIBS"],
+ [LIBS="-l$pthread_lib $LIBS"])])
else
AC_MSG_WARN("Don't know how to find pthread library on your system -- thread support disabled")
fi