summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-07-29 07:17:32 +0000
committernaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-07-29 07:17:32 +0000
commit63bbbdb6fb1b40b76547c777c3a50bb5d628105b (patch)
tree8c844ed33a6be6c7acb6cc374d5cb7b456d05807 /configure.in
parent60053a0a506440f773da92b09204bde854f4f471 (diff)
* configure.in (enable_pthread): use -pthread on OpenBSD without
explicit option. patched by Jeremy Evans. [ruby-core:38572] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@32730 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 29c5c126eb..b278942689 100644
--- a/configure.in
+++ b/configure.in
@@ -1805,7 +1805,9 @@ if test x"$enable_pthread" = xyes; then
[c], [],
[root], [],
[c_r], [MAINLIBS="-pthread $MAINLIBS"],
- [LIBS="-l$pthread_lib $LIBS"])
+ [AS_CASE(["$target_os"],
+ [openbsd*], [LIBS="-pthread $LIBS"],
+ [LIBS="-l$pthread_lib $LIBS"])])
else
AC_MSG_WARN("Don't know how to find pthread library on your system -- thread support disabled")
fi