summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 9226dc980f..e49b8d3bf5 100644
--- a/configure.in
+++ b/configure.in
@@ -709,7 +709,10 @@ if test "$enable_pthread" = "yes"; then
fi
AC_CHECK_FUNC(nanosleep)
if test "$ac_cv_func_nanosleep" = "no"; then
- AC_CHECK_LIB(rt, nanosleep, AC_DEFINE(HAVE_NANOSLEEP))
+ AC_CHECK_LIB(rt, nanosleep)
+ if test "$ac_cv_lib_rt_nanosleep" = "yes"; then
+ AC_DEFINE(HAVE_NANOSLEEP)
+ fi
fi
fi
if test $ac_cv_header_ucontext_h = yes; then