summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 0 insertions, 12 deletions
diff --git a/configure.in b/configure.in
index 04bdbb926c..c23f691325 100644
--- a/configure.in
+++ b/configure.in
@@ -2352,23 +2352,11 @@ if test x"$enable_pthread" = xyes; then
AC_CHECK_FUNCS(pthread_attr_init)
fi
fi
-FIBER_USE_NATIVE=0
if test x"$ac_cv_header_ucontext_h" = xyes; then
if test x"$rb_with_pthread" = xyes; then
AC_CHECK_FUNCS(getcontext setcontext)
- if test x"$ac_cv_func_getcontext" = xyes -a x"$ac_cv_func_setcontext" = xyes; then
- AS_CASE("$target_cpu-$target_os",
- [*-netbsd*], [],
- [ia64-*], [], # r38766
- [*-sunos*|*-solaris*], [], # r32408
- [FIBER_USE_NATIVE=1])
- fi
fi
-else
- AS_CASE("$target_os", [mingw*|mswin*],
- [test "[$[with_winnt_ver]]" -ge [$[0x0400]] && FIBER_USE_NATIVE=1])
fi
-AC_DEFINE(FIBER_USE_NATIVE)
if test "$ac_cv_func_fork" = "yes" -a "$rb_with_pthread" = "yes"; then
AC_CACHE_CHECK([if fork works with pthread], rb_cv_fork_with_pthread,