summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2007-08-16 07:48:49 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2007-08-16 07:48:49 +0000
commitff31ae014108aedc48223aafd0b941e735402fce (patch)
tree2f9fe61134ef01aedfa30c481b213da6723cf597 /configure.in
parent29ab4251f721c64324202357310cba16aa34a2c0 (diff)
* configure.in (BASERUBY): check if base ruby is runnable first.
[ruby-core:11900] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@13063 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in35
1 files changed, 18 insertions, 17 deletions
diff --git a/configure.in b/configure.in
index dfa56aaf32..653fda5953 100644
--- a/configure.in
+++ b/configure.in
@@ -3,6 +3,24 @@ AC_INIT()
AC_PREREQ(2.58)
+AC_ARG_WITH(baseruby,
+ [ --with-baseruby=RUBY use RUBY as baseruby; RUBY is the pathname of ruby],
+ [
+ case "$withval" in
+ *ruby*)
+ BASERUBY=$withval
+ ;;
+ *)
+ AC_MSG_ERROR(need ruby)
+ ;;
+ esac
+ ],
+ [
+ BASERUBY="ruby"
+ ])
+test "`$BASERUBY -e 'p 42' 2>/dev/null`" = 42 ||
+ AC_MSG_ERROR([executable host ruby is required. use --with-baseruby option.])
+
AC_DEFUN([RUBY_MINGW32],
[case "$host_os" in
cygwin*)
@@ -1649,23 +1667,6 @@ if test -z "$MANTYPE"; then
fi
AC_SUBST(MANTYPE)
-AC_ARG_WITH(baseruby,
- [ --with-baseruby=RUBY use RUBY as baseruby; RUBY is the pathname of ruby],
- [
- case "$withval" in
- *ruby*)
- BASERUBY=$withval
- ;;
- *)
- AC_MSG_ERROR(need ruby)
- ;;
- esac
- ],
- [
- BASERUBY="ruby"
- ])
-AC_SUBST(BASERUBY)
-
arch_hdrdir="${EXTOUT}/include/${arch}/ruby"
$MAKEDIRS "${arch_hdrdir}"
config_h="${arch_hdrdir}/config.h"