summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-05-25 11:31:52 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-05-25 11:31:52 +0000
commitfc0920e36d2922a976a8b61f0f3441ca5b3f4b1c (patch)
tree7b674b6d034f2e1fb92d7a0b4ef6cff14d97bc4a /configure.in
parent2d868906714909eac78347d90c8d638fbed22702 (diff)
configure.in: do not disable ucontext.h
* configure.in (ac_cv_func_{getcontext,setcontext}): do not disable ucontext.h entirely, but disable use of functions only. `ucontext_t` is necessary in the signal handler now. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@46114 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 9a4c963f77..4710237a5d 100644
--- a/configure.in
+++ b/configure.in
@@ -969,7 +969,8 @@ AS_CASE(["$target_os"],
[macosx_10_5=yes], [macosx_10_5=no])
AC_MSG_RESULT($macosx_10_5)
if test $macosx_10_5 = yes; then
- ac_cv_header_ucontext_h=no
+ ac_cv_func_getcontext=no
+ ac_cv_func_setcontext=no
else
AC_DEFINE(BROKEN_SETREUID, 1)
AC_DEFINE(BROKEN_SETREGID, 1)