summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-06-11 11:27:08 +0000
committernaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-06-11 11:27:08 +0000
commitf658207fe3716bfa6a784c0e857d4579ce03e6b7 (patch)
tree0fceba8c31685649e4898c98ac42ca4253da8a8e /configure.in
parent0a71db8a7497df37b984ea97abfce6b6ffd82df3 (diff)
* configure.in: on checking libexecinfo, don't specify /use/local.
On FreeBSD people must specify --with-opt-dir or --with-execinfo-dir. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@36032 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 2 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index 7b2060e1dc..43948fa1ba 100644
--- a/configure.in
+++ b/configure.in
@@ -2093,17 +2093,9 @@ main(int argc, char *argv[])
fi
AS_CASE(["$target_cpu-$target_os"],
-[*-freebsd*], [
- AC_CHECK_HEADERS([/usr/local/include/execinfo.h])
- if test "x$ac_cv_header__usr_local_include_execinfo_h" = xyes; then :
- RUBY_APPEND_OPTION(CPPFLAGS, -I/usr/local/include)
- LDFLAGS="${LDFLAGS:+$LDFLAGS }-L/usr/local/lib"
- DLDFLAGS="${DLDFLAGS:+$DLDFLAGS }-L/usr/local/lib"
- AC_CHECK_LIB([execinfo], [backtrace])
- fi],
-[x86_64-netbsd*], [
+[*-freebsd*|x86_64-netbsd*], [
AC_CHECK_HEADERS([execinfo.h])
- if test "x$ac_cv_header_execinfo_h" = xyes; then :
+ if test "x$ac_cv_header_execinfo_h" = xyes; then
AC_CHECK_LIB([execinfo], [backtrace])
fi])
AC_CHECK_FUNCS(backtrace)