summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-08-10 04:48:12 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-08-10 04:48:12 +0000
commitf5e2b68a7de0c3a6d0e344732b121bf3212244e3 (patch)
treee48b653d530afe303bae7eb61cdf0254ee2b9ccc /configure.in
parent244bf0adc75aa73fb30ab2876ebcb90db9ec172e (diff)
configure.in: remove SSE options
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@47129 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 0 insertions, 16 deletions
diff --git a/configure.in b/configure.in
index 79a16bc70f..6e2af03168 100644
--- a/configure.in
+++ b/configure.in
@@ -877,22 +877,6 @@ if test "$GCC" = yes; then
for oflag in -fno-fast-math; do
RUBY_TRY_CFLAGS($oflag, [RUBY_APPEND_OPTION(optflags, $oflag)])
done
- AS_CASE(["$target"],
- [*-darwin*], [
- # doesn't seem necessary on Mac OS X
- ],
- [[i[4-6]86*|i386*mingw*]], [
- RUBY_TRY_CFLAGS(-msse2 -mfpmath=sse, [
- RUBY_APPEND_OPTION(XCFLAGS, -msse2 -mfpmath=sse)
- ])
- AS_CASE(["$XCFLAGS"],
- [[*-msse2*]], [
- RUBY_TRY_CFLAGS(-mstackrealign, [
- RUBY_APPEND_OPTION(XCFLAGS, -mstackrealign)
- ])
- ])
- ]
- )
fi
AC_ARG_WITH(opt-dir,