summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorshugo <shugo@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-01-30 05:47:15 +0000
committershugo <shugo@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-01-30 05:47:15 +0000
commitf1e4777d45f9feea43cd8ca5a65752352bbfa4ec (patch)
tree8810604847cc0f15a7d1837d568db4b55fa7a224 /configure.in
parent044ef87328be54e673b52a2e009d110520fadaa9 (diff)
* configure.in: use $@ instead of $(.TARGET) because .TARGET is not
supported by GNU make. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@44756 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index afe9edda4d..836ae16e74 100644
--- a/configure.in
+++ b/configure.in
@@ -2664,7 +2664,7 @@ if test "$with_dln_a_out" != yes; then
: ${LDSHARED='$(CC) -shared'}
if test "$rb_cv_binary_elf" = yes; then
LDFLAGS="$LDFLAGS -rdynamic"
- DLDFLAGS="$DLDFLAGS "'-Wl,-soname,$(.TARGET)'
+ DLDFLAGS="$DLDFLAGS "'-Wl,-soname,$@'
else
test "$GCC" = yes && test "$rb_cv_prog_gnu_ld" = yes || LDSHARED='$(LD) -Bshareable'
fi