summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-05-27 22:39:24 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-05-27 22:39:24 +0000
commitf0371f2f28b0a0138bf7d56efdc481f4627afe00 (patch)
treeec6ae9e4a5fb471b1f09f455b889d72e4a82b611 /configure.in
parent62005d344bcea9bc589876fc174f72f1fd556ff8 (diff)
* configure.in (THREAD_MODEL): reject unknown value and checks
pthread.h only when pthread. [ruby-core:23577] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@23601 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index f03dbfe309..60efa337c1 100644
--- a/configure.in
+++ b/configure.in
@@ -930,7 +930,7 @@ AC_HEADER_SYS_WAIT
AC_CHECK_HEADERS(limits.h sys/file.h sys/ioctl.h sys/syscall.h\
fcntl.h sys/fcntl.h sys/select.h sys/time.h sys/times.h sys/param.h\
syscall.h pwd.h grp.h a.out.h utime.h direct.h sys/resource.h \
- sys/mkdev.h sys/utime.h xti.h netinet/in_systm.h float.h ieeefp.h pthread.h \
+ sys/mkdev.h sys/utime.h xti.h netinet/in_systm.h float.h ieeefp.h \
ucontext.h intrinsics.h langinfo.h locale.h sys/sendfile.h time.h \
net/socket.h sys/socket.h)
@@ -2167,6 +2167,17 @@ case "$target_os" in
esac
MINIOBJS="$MINIDLNOBJ"
+case "$THREAD_MODEL" in
+when(pthread)
+ AC_CHECK_HEADERS(pthread.h)
+ ;;
+when(win32)
+ ;;
+when(*)
+ AC_MSG_ERROR(unknown thread model $THREAD_MODEL)
+ ;;
+esac
+
case "$FIRSTMAKEFILE" in
when(*GNUmakefile:*)
gnumake=yes