summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2006-08-12 06:56:09 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2006-08-12 06:56:09 +0000
commitedcb8975ac13b9b0dd392b3a8c18cef64546b010 (patch)
tree5acf171b97b3bb42bf8f4ee3581dd79f3f427637 /configure.in
parent0fe7592d74ce3553a949af420455362564b8e7b7 (diff)
* configure.in, bcc32/Makefile.sub, win32/Makefile.sub, win32/dir.h,
win32/win32.c, win32/win32.h: large file support for win32. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@10720 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 0feaa29ab8..a9b1874bfb 100644
--- a/configure.in
+++ b/configure.in
@@ -218,6 +218,13 @@ fi
dnl check for large file stuff
AC_SYS_LARGEFILE
+case "$target_os" in
+mingw*)
+ ac_cv_type_off_t=yes
+ ac_cv_sizeof_off_t=8
+ ;;
+esac
+
AC_CHECK_TYPES([long long, off_t])
AC_CHECK_SIZEOF(int, 4)
@@ -378,6 +385,9 @@ mingw*) LIBS="-lshell32 -lws2_32 $LIBS"
ac_cv_func_isnan=yes
ac_cv_func_finite=yes
ac_cv_func_link=yes
+ ac_cv_func_truncate=yes
+ ac_cv_func_fseeko=yes
+ ac_cv_func_ftello=yes
ac_cv_lib_crypt_crypt=no
ac_cv_func_getpgrp_void=no
ac_cv_func_setpgrp_void=yes