summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoreban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2001-04-22 09:49:15 +0000
committereban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2001-04-22 09:49:15 +0000
commiteccb4d021056cd77393885c5889c7ea2003f606a (patch)
treebf14dc89ee0ace635fd8a0ba21dc8fa101d2fc9f /configure.in
parentcc8165ad232263b8cf9b20697490564ed5e7d10f (diff)
* configure.in: add -mieee to CFLAGS on Linux/Alpha
to disable "DIVISION BY ZERO" exception. * configure.in: remove -ansi on OSF/1. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@1331 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 9171203105..9cd889871f 100644
--- a/configure.in
+++ b/configure.in
@@ -251,6 +251,11 @@ freebsd*) LIBS="-lm $LIBS"
fi
fi
;;
+linux*) LIBS="-lm $LIBS"
+ case "$target_cpu" in
+ alpha*)
+ CFLAGS="-mieee $CFLAGS" ;;
+ esac ;;
*) LIBS="-lm $LIBS";;
esac
AC_CHECK_LIB(crypt, crypt)
@@ -925,9 +930,7 @@ case "$target_os" in
CFLAGS="$CFLAGS -DOS2"
;;
osf*)
- if test "$without_gcc" = "no" ; then
- CFLAGS="$CFLAGS -ansi"
- else
+ if test "$without_gcc" = "yes" ; then
# compile something small: taint.c is fine for this.
# the main point is the '-v' flag of 'cc'.
case "`cc -v -I. -c main.c -o /tmp/main.o 2>&1`" in