summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2010-02-03 13:22:32 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2010-02-03 13:22:32 +0000
commitec7872aff7027a88dba1844ed080d5a8a1f9799c (patch)
tree5ff7b34dee60664fb4943edb03441c33d409c4fa /configure.in
parentf9994ada30ebe19a350ee79229968a206481d4c2 (diff)
* configure.in: check for non-portable stack attribute functions.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@26556 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index da83bcc851..69b8b7170a 100644
--- a/configure.in
+++ b/configure.in
@@ -1507,7 +1507,10 @@ if test x"$enable_pthread" = xyes; then
else
AC_MSG_WARN("Don't know how to find pthread library on your system -- thread support disabled")
fi
- AC_CHECK_FUNCS(nanosleep sched_yield pthread_attr_setinheritsched)
+ AC_CHECK_FUNCS(nanosleep sched_yield pthread_attr_setinheritsched \
+ pthread_getattr_np pthread_attr_get_np \
+ pthread_get_stackaddr_np pthread_get_stacksize_np \
+ thr_stksegment pthread_stackseg_np)
if test x"$ac_cv_func_nanosleep" = xno; then
AC_CHECK_LIB(rt, nanosleep)
if test x"$ac_cv_lib_rt_nanosleep" = xyes; then