summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2015-01-26 08:14:17 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2015-01-26 08:14:17 +0000
commitec723e30bc56f098741e1196a70c73096e7ab010 (patch)
treeceec924d18b030b645f7d699ba997273d8789d90 /configure.in
parent79cab4f31e89b05b1ee4c286ff4eb1ac9dfaa531 (diff)
configure.in: check dtace -G
* configure.in (RUBY_DTRACE_POSTPROCESS): check if the object file is really modified by `dtrace -G`, this command is very system dependent. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@49411 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 449c3c5c46..85df4a5266 100644
--- a/configure.in
+++ b/configure.in
@@ -643,7 +643,9 @@ _PROBES
int main(void){ CONFTEST_FIRE(); return 0; }
_CONF
$CC $CFLAGS $CPPFLAGS -c -o conftest.o conftest.c &&
- $DTRACE -G -s conftest_provider.d conftest.o 2>/dev/null
+ cp -p conftest.o conftest.oo &&
+ $DTRACE -G -s conftest_provider.d conftest.o 2>/dev/null &&
+ ! cmp -b conftest.o conftest.oo
}; then
rb_cv_prog_dtrace_g=yes
else