summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoryugui <yugui@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2013-01-04 09:04:58 +0000
committeryugui <yugui@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2013-01-04 09:04:58 +0000
commitea9301bd2bf814438e31c6d5d9e78354b75752c1 (patch)
tree157dbe8ece8e4f32b11ab5fc62981f0a6ce7b792 /configure.in
parent2d08d23e9cdd13616d8819aa7a582d3a5838636f (diff)
* common.mk (yes-btest): btest depends on also $(arch)-fake.rb and
rbconfig.rb on building for NativeClient. * Makefile.in (fake): Avoid generating $(arch)-fake.rb unless cross compiling. * configure.in (CROSS_COMPILING): New substitution. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@38692 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index f6b0b57851..5475abc278 100644
--- a/configure.in
+++ b/configure.in
@@ -2525,6 +2525,7 @@ if test x"$cross_compiling" = xyes; then
RUNRUBY='$(MINIRUBY) -I`cd $(srcdir)/lib; pwd`'
XRUBY='$(MINIRUBY)'
TEST_RUNNABLE=no
+ CROSS_COMPILING=yes
if test "$host_os" = "nacl"; then
if test "$build_cpu" = "$host_cpu" || test "${nacl_cv_cpu_nick}" = "x86" -a "$host_cpu" = "i686"; then
@@ -2546,8 +2547,10 @@ else
RUNRUBY='$(MINIRUBY) $(srcdir)/tool/runruby.rb --extout=$(EXTOUT)'
XRUBY='$(RUNRUBY)'
TEST_RUNNABLE=yes
+ CROSS_COMPILING=no
fi
AC_SUBST(TEST_RUNNABLE)
+AC_SUBST(CROSS_COMPILING)
AC_SUBST(MINIRUBY)
AC_SUBST(BTESTRUBY)
AC_SUBST(PREP)