summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2010-11-09 12:13:06 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2010-11-09 12:13:06 +0000
commite9c4a44f238153114d91b5996bc8cb04e7a573a0 (patch)
treebbbfde084dc6e6861f7c48d282342d40e85be6e0 /configure.in
parentac21a6ef7db04faa703a3b010c7dc591b50af75c (diff)
* configure.in (EXPORT_PREFIX): check generic prefix.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@29734 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index dc8cb7cf39..808bba8a41 100644
--- a/configure.in
+++ b/configure.in
@@ -2346,13 +2346,16 @@ AC_SUBST(INSTALLDOC)
if test "$rb_with_pthread" = "yes"; then
THREAD_MODEL=pthread
fi
-AC_CACHE_CHECK([for prefixed underscore of exported symbols], rb_cv_export_prefix, [
+AC_CACHE_CHECK([for prefix of exported symbols], rb_cv_export_prefix, [
AC_TRY_COMPILE([extern void conftest_exported(void) {}], [], [
rb_cv_export_prefix=`$NM conftest.$ac_objext |
- sed -n ['/.*\(_\)conftest_exported.*/!d;s//\1/p;q']`
+ sed -n ['/.*[ ]\([^ ]*\)conftest_exported.*/!d;s//\1/p;q']`
],
[rb_cv_export_prefix=''])
+ test -n "$rb_cv_export_prefix" || rb_cv_export_prefix=NONE
])
+EXPORT_PREFIX="$rb_cv_export_prefix"
+test "x$EXPORT_PREFIX" = xNONE && EXPORT_PREFIX=''
MINIDLNOBJ=dmydln.o
AS_CASE(["$target_os"],
[linux*], [
@@ -2418,8 +2421,7 @@ AS_CASE(["$target_os"],
LIBRUBY_SO='$(RUBY_SO_NAME)'.dll
LIBRUBY_DLDFLAGS="${LIBRUBY_DLDFLAGS}"' $(RUBYDEF)'
fi
- test -z "$rb_cv_export_prefix" && rb_cv_export_prefix=' '
- EXPORT_PREFIX="$rb_cv_export_prefix"
+ test -z "$EXPORT_PREFIX" && EXPORT_PREFIX=' '
DLDFLAGS="${DLDFLAGS}"' $(DEFFILE)'
AC_LIBOBJ([win32])
COMMON_LIBS=m