summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2013-08-18 03:41:56 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2013-08-18 03:41:56 +0000
commite7ad24266336b8d8e17a244c51b3e3dbba45ef5c (patch)
tree70b9fa4fac71cbf7aafeb798b4ab75454bd982d1 /configure.in
parent364237623b683d15e94b228ceea3ce2fbaf7dceb (diff)
configure.in: clock_gettime
* configure.in (clock_gettime): need to check with -lrt prior to check for the function only. otherwise -lrt is not linked and the link fails, when ac_cv_func_clock_gettime is cached as yes. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@42604 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 4 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 62aaf72f5f..d1a42d9eb8 100644
--- a/configure.in
+++ b/configure.in
@@ -1748,7 +1748,6 @@ AC_CHECK_FUNCS(_setjmp) # used for AC_ARG_WITH(setjmp-type)
AC_CHECK_FUNCS(_setjmpex) # used for AC_ARG_WITH(setjmp-type)
AC_CHECK_FUNCS(chroot)
AC_CHECK_FUNCS(chsize)
-AC_CHECK_FUNCS(clock_gettime)
AC_CHECK_FUNCS(cosh)
AC_CHECK_FUNCS(daemon)
AC_CHECK_FUNCS(dl_iterate_phdr)
@@ -1856,13 +1855,13 @@ RUBY_CHECK_BUILTIN_FUNC(__builtin_clzl, [__builtin_clzl(0)])
RUBY_CHECK_BUILTIN_FUNC(__builtin_clzll, [__builtin_clzll(0)])
# Some platform need -lrt for clock_gettime, but the other don't.
-if test x"$ac_cv_func_clock_gettime" != xyes; then
+AC_CHECK_LIB(rt, clock_gettime)
+if test x"$ac_cv_lib_rt_clock_gettime" = xyes; then
# glibc 2.17 moves clock_* functions from librt to the main C library.
# http://sourceware.org/ml/libc-announce/2012/msg00001.html
- AC_CHECK_LIB(rt, clock_gettime)
- unset ac_cv_func_clock_gettime
- AC_CHECK_FUNCS(clock_gettime)
+ ac_cv_func_clock_gettime="$ac_cv_lib_rt_clock_gettime"
fi
+AC_CHECK_FUNCS(clock_gettime)
AC_CACHE_CHECK(for unsetenv returns a value, rb_cv_unsetenv_return_value,
[AC_TRY_COMPILE([