summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoreban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2003-05-13 11:34:48 +0000
committereban <eban@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2003-05-13 11:34:48 +0000
commite4ada45df17a2ccda0073db6fc586ee1641337e4 (patch)
treea0a250a25f28b2047c22b8367f085fd2336fb0fa /configure.in
parent161e19ded988df158b4bec5fca0f4f977fa581e8 (diff)
* configure.in: add '--Wl,--enable-auto-import' to DLDFLAGS
on Cygwin/MinGW. * configure.in: add '-D_USE_CRTIMP' to XCFLAGS on MinGW. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@3786 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 08bc2e5280..c2f7c10e5a 100644
--- a/configure.in
+++ b/configure.in
@@ -833,7 +833,7 @@ if test "$with_dln_a_out" != yes; then
rb_cv_dlopen=yes;;
cygwin*|mingw*) : ${LDSHARED="${CC} -shared -s"}
XLDFLAGS='-Wl,--stack,0x02000000'
- DLDFLAGS="${DLDFLAGS} "'$(DEFFILE)'
+ DLDFLAGS="${DLDFLAGS} -Wl,--enable-auto-import "'$(DEFFILE)'
rb_cv_dlopen=yes ;;
hiuxmpp) LDSHARED='ld -r' ;;
atheos*) LDSHARED="$CC -shared"
@@ -1178,6 +1178,7 @@ case "$target_os" in
COMMON_LIBS=m
COMMON_MACROS="WIN32_LEAN_AND_MEAN="
COMMON_HEADERS="windows.h winsock.h"
+ XCFLAGS='-D__USE_CRTIMP'
;;
esac
XCFLAGS="$XCFLAGS -DRUBY_EXPORT"