summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-11-16 08:57:17 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-11-16 08:57:17 +0000
commitdf4e0dd52d15028fc13dababa2d95d77a33bdb7e (patch)
treee545e37131d283c926b2c73e1ac49066af284863 /configure.in
parente516438581a6ff13b994aaed48963b4e0720fbd0 (diff)
Makefile.in: split probes.h commands
* Makefile.in (probes.h): split build commands for dtrace-available and unavailable platforms. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@37679 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index ee9ea8a112..0be5ad35dd 100644
--- a/configure.in
+++ b/configure.in
@@ -395,6 +395,12 @@ fi
AS_CASE(["$target_os"],
[freebsd*], [DTRACE=]
)
+if test -n "$DTRACE"; then
+ DTRACE_AVAILABLE=yes
+else
+ DTRACE_AVAILABLE=no
+fi
+AC_SUBST(DTRACE_AVAILABLE)
RUBY_PROG_GNU_LD
RUBY_CPPOUTFILE