summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-01-01 02:12:38 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-01-01 02:12:38 +0000
commitdd6834b05415ad947c153c649eea7b2eb14ed2af (patch)
tree8241406f43ce5ad62b99da7f2b0a7e4d3b7735f1 /configure.in
parent8a46d4027c5d797eb07afe24d43c37aaa5e33c5d (diff)
configure.in: use SSE2
* configure.in: use SSE2 instructions for drop unexpected precisions. [ruby-core:54738] [Bug #8358] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@44474 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index ad89e44b16..60ab5777ac 100644
--- a/configure.in
+++ b/configure.in
@@ -801,6 +801,7 @@ if test "$GCC" = yes; then
# various headers. Most frequent situation is the use of //
# comments. We bypass ANSI C mode for them. Otherwise
# extension libs cannot include those headers.
+ RUBY_TRY_CFLAGS(-msse2 -mfpmath=sse, [RUBY_APPEND_OPTION(XCFLAGS, -msse2 -mfpmath=sse)])
],
[cygwin*|darwin*|netbsd*], [
# need lgamma_r(), finite()