summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorknu <knu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2004-06-09 06:41:08 +0000
committerknu <knu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2004-06-09 06:41:08 +0000
commitd918f9f34fd189cb0adc947a16792389104de623 (patch)
tree0b9e1f614e29010007eff002c418e5c6b979f147 /configure.in
parent505d19848ee7a6325d201d81706ad0449e95026a (diff)
* configure.in: Add support for DragonFly BSD.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@6436 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 5dd8cbdc16..6160643eb6 100644
--- a/configure.in
+++ b/configure.in
@@ -352,6 +352,8 @@ freebsd*) LIBS="-lm $LIBS"
fi
fi
;;
+dragonfly*) LIBS="-lm $LIBS"
+ ;;
bow) ac_cv_func_setitimer=no
;;
superux*) ac_cv_func_setitimer=no
@@ -869,7 +871,7 @@ if test "$with_dln_a_out" != yes; then
gnu*) : ${LDSHARED="$CC -shared"}
rb_cv_dlopen=yes
LDFLAGS="$LDFLAGS -rdynamic" ;;
- freebsd*) : ${LDSHARED="$CC -shared"}
+ freebsd*|dragonfly*) : ${LDSHARED="$CC -shared"}
if test "$rb_cv_binary_elf" = yes; then
LDFLAGS="$LDFLAGS -rdynamic"
DLDFLAGS="$DLDFLAGS "'-Wl,-soname,$(.TARGET)'
@@ -1170,7 +1172,7 @@ if test "$enable_shared" = 'yes'; then
LIBRUBY_DLDFLAGS='-Wl,-soname,lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR)'
LIBRUBY_ALIASES='lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR) lib$(RUBY_SO_NAME).so'
;;
- freebsd*)
+ freebsd*|dragonfly*)
SOLIBS='$(LIBS)'
LIBRUBY_SO='lib$(RUBY_SO_NAME).so.$(MAJOR)$(MINOR)'
if test "$rb_cv_binary_elf" != "yes" ; then