summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-03-04 14:29:58 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-03-04 14:29:58 +0000
commitd34f9699fc3adf72e40e4eb3f837eaf8ee60137f (patch)
tree94dabd1933396f1c6d66153de45c2292b8c333cd /configure.in
parent40c2dd156bd983d5f7a6cf85a11b4977f3720fef (diff)
* configure.in, win32/configure.bat (--enable-win95): new option
to enable/disable win95 support. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@22766 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 1946ffcead..81020f8de7 100644
--- a/configure.in
+++ b/configure.in
@@ -551,6 +551,12 @@ dnl Check whether we need to define sys_nerr locally
AC_CHECK_DECLS([sys_nerr], [], [], [$ac_includes_default
#include <errno.h>])
+AC_ARG_ENABLE(win95, [ --enable-win95 enable Windows 95 series support]
+ [case "$enableval" in
+ when(yes|no) enable_win95=$enableval;;
+ when(*) unset enable_win95;;
+ esac])
+
case "$target_os" in
when(freebsd*)
AC_CACHE_CHECK([whether pthread should be enabled by default],
@@ -709,8 +715,7 @@ when(mingw*) LIBS="-lshell32 -lws2_32 $LIBS"
ac_cv_func_fcntl=yes
ac_cv_func_flock=yes
AC_LIBOBJ([langinfo])
- AC_HAVE_LIBRARY(unicows, [LIBS="-lunicows $LIBS"
- AC_DEFINE(WIN95)])
+ : ${enable_win95=maybe}
;;
when(os2-emx*) LIBS="-lm $LIBS"
ac_cv_lib_dir_opendir=no;;
@@ -742,6 +747,13 @@ AC_CHECK_LIB(dl, dlopen) # Dynamic linking for SunOS/Solaris and SYSV
AC_CHECK_LIB(dld, shl_load) # Dynamic linking for HP-UX
AC_CHECK_LIB(socket, socketpair) # SunOS/Solaris
AC_CHECK_LIB(rt, clock_gettime) # GNU/Linux
+if test "${enable_win95}" = maybe; then
+ AC_HAVE_LIBRARY(unicows, [enable_win95=yes], [enable_win95=no])
+fi
+if test "${enable_win95}" = yes; then
+ AC_DEFINE(WIN95)
+ LIBS="-lunicows $LIBS"
+fi
case "$target_cpu" in
when(alpha*) case "$target_os"::"$GCC" in