summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2008-12-24 04:33:39 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2008-12-24 04:33:39 +0000
commitd1af8511af633f8bd7415f29f64c31d031b6a2af (patch)
tree2bb5a460b31d717d85a880bc63425d0f4a75988c /configure.in
parent39711b631f91d58ba3a2401563e6b66f2f119e67 (diff)
* configure.in (HAVE_LONG_LONG, HAVE_OFF_T): revised for autoconf
2.62 or later. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@20964 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 98019dea1e..7547dd94b4 100644
--- a/configure.in
+++ b/configure.in
@@ -281,6 +281,8 @@ mingw*)
;;
esac
+AC_CHECK_TYPES([long long, off_t])
+
AC_CHECK_SIZEOF(int, 4)
AC_CHECK_SIZEOF(short, 2)
AC_CHECK_SIZEOF(long, 4)
@@ -292,9 +294,6 @@ AC_CHECK_SIZEOF(float, 4)
AC_CHECK_SIZEOF(double, 8)
AC_CHECK_SIZEOF(time_t, 0)
-[test "${ac_cv_type_long_long}" = yes] && AC_DEFINE(HAVE_LONG_LONG)
-[test "${ac_cv_type_off_t}" = yes] && AC_DEFINE(HAVE_OFF_T)
-
dnl RUBY_REPLACE_TYPE [typename] [default type] [macro type] [included]
AC_DEFUN([RUBY_REPLACE_TYPE], [dnl
AC_CHECK_TYPE([$1],