summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-09-13 01:22:13 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-09-13 01:22:13 +0000
commitd11ef850b21cadc92b8b2bb509c3a329dc70cd43 (patch)
tree20bbc0d33ba35a1473f455a9e50a841fb49b281b /configure.in
parent5d62cf1376bbe6ee14a3e9bfae5b407d6cf9a4ef (diff)
configure.in: no PIE on Haiku
* configure.in: Don't use PIE on Haiku because loader support is not enough. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@36957 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 95787f5d85..5131952682 100644
--- a/configure.in
+++ b/configure.in
@@ -2676,7 +2676,13 @@ AS_CASE("$enable_shared", [yes], [
LIBRUBYARG_SHARED=
# enable PIE if possible
- if test "$GCC" = yes -a -z "$EXTSTATIC"; then
+ pie=
+ AS_CASE(["$target_os"],
+ [haiku], [
+ # gcc supports PIE, but doesn't work correctly in Haiku
+ pie=no
+ ])
+ if test "$GCC" = yes -a -z "$EXTSTATIC" -a "x$pie" != xno; then
RUBY_TRY_CFLAGS(-fPIE, [pie=yes], [pie=no])
if test "$pie" = yes; then
RUBY_APPEND_OPTION(XCFLAGS, -fPIE)