summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-07-20 02:13:00 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-07-20 02:13:00 +0000
commitce34147cf4de2212b77d11d83a8e4cbd9df52683 (patch)
tree4f4aa8517faf83ce673555faa15b74d6332eff59 /configure.in
parent1a36dbe3ba91c7254169f67f0142680eb05aeaa8 (diff)
* configure.in, Makefile.in (TEST_RUNNABLE): tests are not
runnable if cross-compiling. * common.mk (btest*, test*): ditto. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@24209 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8779e983a1..a2a7c594eb 100644
--- a/configure.in
+++ b/configure.in
@@ -1910,12 +1910,15 @@ if test x"$cross_compiling" = xyes; then
test x"$MINIRUBY" = x && MINIRUBY="${RUBY-ruby} -I`pwd` "-r'$(arch)-fake'
PREP='$(arch)-fake.rb'
RUNRUBY='$(MINIRUBY) -I`cd $(srcdir)/lib; pwd`'
+ TEST_RUNNABLE=no
else
MINIRUBY='./miniruby$(EXEEXT) -I$(srcdir)/lib'
MINIRUBY="$MINIRUBY"' -I$(EXTOUT)/common -I./- -r$(srcdir)/ext/purelib.rb'
PREP='miniruby$(EXEEXT)'
RUNRUBY='$(MINIRUBY) $(srcdir)/tool/runruby.rb --extout=$(EXTOUT)'
+ TEST_RUNNABLE=yes
fi
+AC_SUBST(TEST_RUNNABLE)
AC_SUBST(MINIRUBY)
AC_SUBST(PREP)
AC_SUBST(RUNRUBY)