summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-03-22 05:59:48 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-03-22 05:59:48 +0000
commitcd71db0ad6c0382e99c0ba7fe5e5cfadedbe5557 (patch)
tree8c10c68612e24a59eca27da5e65147b8d8ce94cc /configure.in
parent11c57111f94ce73fba40ac3649001a8810ec7f9b (diff)
* configure.in (Makefile): check with svn info, since svn 1.7 doesn't
have .svn under descendent directories. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@35105 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 8 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 1785164df3..e6d6829a39 100644
--- a/configure.in
+++ b/configure.in
@@ -3051,19 +3051,22 @@ AS_CASE([" $CPP "], [*" $CC "*], [CPP=`echo " $CPP " | sed "s| $CC |"' $(CC) |;s
AC_CONFIG_FILES($FIRSTMAKEFILE)
AC_CONFIG_FILES(Makefile, [{
- if test -d "$srcdir/.svn"; then
+ if ${VCS+set}; then
+ :
+ elif svn info "$srcdir" > /dev/null 2>&1; then
VCS='svn'
- VCSUP='$(VCS) up $(SVNUPOPTIONS)'
elif test -d "$srcdir/.git/svn"; then
VCS='git svn'
- VCSUP='$(VCS) rebase $(GITSVNREBASEOPTIONS)'
elif test -d "$srcdir/.git"; then
VCS='git'
- VCSUP='$(VCS) pull $(GITPULLOPTIONS)'
else
VCS='echo cannot'
- VCSUP='$(VCS)'
fi
+ AS_CASE("$VCS",
+ [svn], [VCSUP='$(VCS) up $(SVNUPOPTIONS)'],
+ ["git svn"], [VCSUP='$(VCS) rebase $(GITSVNREBASEOPTIONS)'],
+ [git], [VCSUP='$(VCS) pull $(GITPULLOPTIONS)'],
+ [VCSUP='$(VCS)'])
sed '/^MISSING/s/\$U\././g;/^VCS *=/s#@VCS@#'"$VCS"'#;/^VCSUP *=/s#@VCSUP@#'"$VCSUP"'#' Makefile
echo; test x"$EXEEXT" = x || echo 'miniruby: miniruby$(EXEEXT)'
if test "$gnumake" != yes; then