summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoryugui <yugui@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2013-01-06 09:48:00 +0000
committeryugui <yugui@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2013-01-06 09:48:00 +0000
commitc9f5a8f3f2a18b1a2e283d29e906471dade5f3be (patch)
tree8db79e72a6f0a9450ff08b2d23d49964df3c8727 /configure.in
parent015997ecde57588a5ae850b0c27751162cbc0cf4 (diff)
* bootstraptest/test_io.c: add a test for [ruby-dev:46834].
* io.c (rb_cloexec_fcntl_dupfd) Use an emulation with dup(2) when fcntl(2) and/or F_DUPFD is unavailable. Suggested by akr. * configure.in (HAVE_FCNTL): NativeClient does not provide fcntl(2). git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@38713 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 5475abc278..b87b325248 100644
--- a/configure.in
+++ b/configure.in
@@ -1302,6 +1302,7 @@ $POSTLINK"
RUBY_APPEND_OPTION(XCFLAGS, -fPIC)
fi
ac_cv_func_shutdown=no
+ ac_cv_func_fcntl=no
],
[ LIBS="-lm $LIBS"])
AC_CHECK_LIB(crypt, crypt)
@@ -1576,7 +1577,7 @@ AC_CHECK_FUNCS(fmod killpg wait4 waitpid fork spawnv syscall __syscall chroot ge
setuid setgid daemon select_large_fdset setenv unsetenv\
mktime timegm gmtime_r clock_gettime gettimeofday poll ppoll\
pread sendfile shutdown sigaltstack dl_iterate_phdr\
- dup3 pipe2 posix_memalign memalign ioctl)
+ dup dup3 pipe2 posix_memalign memalign ioctl)
AC_CACHE_CHECK(for unsetenv returns a value, rb_cv_unsetenv_return_value,
[AC_TRY_COMPILE([