summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorusa <usa@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2015-11-17 10:05:04 +0000
committerusa <usa@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2015-11-17 10:05:04 +0000
commitc88764f369ddaa9661a0b0c4ca121232f7f1513e (patch)
tree2b51815708e31ff238c02e90bbe28b8228c30049 /configure.in
parenta2f72abb0f4b4c9ea2c805bb965d74f4054a4d91 (diff)
* configure.in (BASERUBY): use Kernel#print instead of Kernel#p because
the baseruby may output CRLF as end of line. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@52616 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index e97871d110..eae8b06a34 100644
--- a/configure.in
+++ b/configure.in
@@ -41,8 +41,8 @@ AC_ARG_WITH(baseruby,
[
BASERUBY="ruby"
])
-if test "`RUBYOPT=- $BASERUBY -e 'p 42' 2>/dev/null`" = 42; then
- if test "`RUBYOPT=- $BASERUBY --disable=gems -e 'p 42' 2>/dev/null`" = 42; then
+if test "`RUBYOPT=- $BASERUBY -e 'print 42' 2>/dev/null`" = 42; then
+ if test "`RUBYOPT=- $BASERUBY --disable=gems -e 'print 42' 2>/dev/null`" = 42; then
BASERUBY="$BASERUBY --disable=gems"
fi
$BASERUBY -C "$srcdir/tool" downloader.rb -e gnu config.guess config.sub