summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-05-11 00:33:45 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-05-11 00:33:45 +0000
commitc6e9e4110e7878cdd13c4b92f79101a2b2e03c97 (patch)
tree71c52e88579f6c1f235963ebde3ec65f3b6b8230 /configure.in
parent7c68a3121cb8495a076f7318067c98daca3c2311 (diff)
configure.in: check typeof
* configure.in (rb_cv_typeof): check typeof extension for ccan headers. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@45916 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index dc96f2f1de..fb3b86e76b 100644
--- a/configure.in
+++ b/configure.in
@@ -1505,6 +1505,12 @@ EOH
])dnl
])dnl
+AC_CACHE_CHECK(for typeof, rb_cv_typeof,
+ [AC_TRY_COMPILE([int i; typeof(i) j;], [], [rb_cv_typeof=yes], [rb_cv_typeof=no])])
+if test "$rb_cv_typeof" = yes; then
+ AC_DEFINE(HAVE_TYPEOF)
+fi
+
dnl RUBY_FUNC_ATTRIBUTE(attrib, macroname, cachevar, condition)
AC_DEFUN([RUBY_FUNC_ATTRIBUTE], [dnl
m4_ifval([$2], dnl