summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-08-03 10:21:22 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-08-03 10:21:22 +0000
commitbea3f0df108ad4a983843eae83231cca2843b30d (patch)
treea2459c8fe6a1dda98baa5109757763818c483592 /configure.in
parenta713b37640079e1f54fcb199541d64387a8ab016 (diff)
configure.in: use default compilers for non-darwin
* configure.in: use clang prior to gcc only when self-compiling on darwin. search default compilers on other platforms. [Bug #6816] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@36611 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 8e20ced700..b3731b6e71 100644
--- a/configure.in
+++ b/configure.in
@@ -369,13 +369,14 @@ if test -z "${CXXFLAGS+set}"; then
fi
RUBY_NACL
+AS_CASE(["$host_os:$build_os"],
+[darwin*:darwin*], [
+ AC_CHECK_TOOLS(CC, [clang gcc cc])
+])
if test x"${build}" != x"${host}"; then
AC_CHECK_TOOL(CC, gcc)
fi
-AS_CASE(["$build_os"],
-[darwin*], [ cc_list="clang gcc cc" ],
- [ cc_list="gcc cc" ])
-AC_PROG_CC([$cc_list])
+AC_PROG_CC
AC_PROG_CXX
RUBY_MINGW32
AC_PROG_GCC_TRADITIONAL