summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-11-20 02:21:17 +0000
committernaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-11-20 02:21:17 +0000
commitbd0931f7b9a39dd48af48ebef5c2a13d7c3e3e56 (patch)
tree0d18e89747cb4781a917db32034d11122435d03f /configure.in
parentb65dda51bd8731a30a94e394c31198427b90a368 (diff)
* configure.in (--enable-dtrace): always call RUBY_DTRACE_BSD_BROKEN
for portability. As the note, FreeBSD 8 has DTrace as the optional feature (it is enabled by the build option), but doesn't have USDT. FreeBSD 9 has USDT but they are still optional. FreeBSD 10 will enable them by default. The variable $rb_cv_prog_dtrace_g is "yes" only on FreeBSD 9 with optional DTrace or FreeBSD 10. If it is "no", you cannnot know whether it doesn't need -G or DTrace is disabled. (by cheking error code, you can know) * configure.in (--enable-dtrace): change help message git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@37742 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 3 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index f2d22ef6f3..80c1c34b37 100644
--- a/configure.in
+++ b/configure.in
@@ -2731,20 +2731,14 @@ fi
AC_ARG_ENABLE(dtrace,
AS_HELP_STRING([--enable-dtrace],
- [enable DTrace for tracing ruby's internal.]),
- [enable_dtrace=$enableval], [enable_dtrace=auto])
+ [enable DTrace for tracing ruby's internal. enabled by default on systems having dtrace]),
+ [enable_dtrace=$enableval], [enable_dtrace=auto])
if test "${enable_dtrace}" = "auto"; then
if test x"$DTRACE" != x -a x"$cross_compiling" != xyes; then
RUBY_DTRACE_POSTPROCESS()
enable_dtrace=yes
- if test "$rb_cv_prog_dtrace_g" = 'yes'; then
- RUBY_DTRACE_BSD_BROKEN([enable_dtrace=no], [enable_dtrace=yes])
- else
- AS_CASE(["$target_os"],
- [freebsd*], [enable_dtrace=no]
- )
- fi
+ RUBY_DTRACE_BSD_BROKEN([enable_dtrace=no], [enable_dtrace=yes])
else
enable_dtrace=no
fi