summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-11-01 13:08:30 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-11-01 13:08:30 +0000
commitb9a7f8b44c26b2d978bbcf33e67ecc1337573944 (patch)
tree8d91b8f85fe0fc1b9b186404400e4d7c7746a710 /configure.in
parentf0bd6396933c38a59167180c03b1ee6c86692932 (diff)
* configure.in: reject llvm-gcc.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@33607 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index a3d191a2bf..5e1c479c12 100644
--- a/configure.in
+++ b/configure.in
@@ -289,6 +289,11 @@ AC_PROG_CXX
AC_PROG_GCC_TRADITIONAL
AC_SUBST(GCC)
if test "$GCC" = yes; then
+ AC_TRY_LINK([
+ @%:@if defined __llvm__ && !defined __clang__
+ @%:@error llvm-gcc has ended
+ @%:@endif
+ ], [], [], [AC_MSG_ERROR(llvm-gcc has ended)])
linker_flag=-Wl,
: ${optflags=-O3}
AS_CASE(["$target_os"], [linux*|darwin*], [: ${debugflags=-ggdb}])