summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-05-16 09:05:59 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-05-16 09:05:59 +0000
commitb85e3e70eee6905e34eb8efae9db9f9eb75d94f8 (patch)
tree119acb35410bb48e85c5983df65387a87d187660 /configure.in
parenta2976afa0e922f8c62abbcb37e88754f347fd056 (diff)
* configure.in (PIE): fix operator.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@35666 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 71c2828124..a398b5ebd7 100644
--- a/configure.in
+++ b/configure.in
@@ -2516,7 +2516,7 @@ AS_CASE("$enable_shared", [yes], [
LIBRUBYARG_SHARED=
# enable PIE if possible
- if test "$GCC" = yes and -z "$EXTSTATIC"; then
+ if test "$GCC" = yes -a -z "$EXTSTATIC"; then
RUBY_TRY_CFLAGS(-fPIE, [pie=yes], [pie=no])
if test "$pie" = yes; then
RUBY_APPEND_OPTION(XCFLAGS, -fPIE)