summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2013-12-03 14:48:20 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2013-12-03 14:48:20 +0000
commitb7c6db94ae2b9532640609163099c738decb31e6 (patch)
tree3ad8430052846cefef81706dc9d4edba1b0964ab /configure.in
parent7e1f3c636b317571141c9a0ca778a088f7c22ccb (diff)
gc.c: use malloc_size
* configure.in: check malloc_size() available on BSD. * gc.c: use malloc_size() with malloc/malloc.h on BSD. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@43983 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8bff18d6dd..88d24eefe8 100644
--- a/configure.in
+++ b/configure.in
@@ -1093,6 +1093,7 @@ AC_CHECK_HEADERS( \
atomic.h \
malloc.h \
malloc_np.h \
+ malloc/malloc.h \
setjmpex.h
)
@@ -1870,6 +1871,7 @@ AC_CHECK_FUNCS(lockf)
AC_CHECK_FUNCS(log2)
AC_CHECK_FUNCS(lstat)
AC_CHECK_FUNCS(malloc_usable_size)
+AC_CHECK_FUNCS(malloc_size)
AC_CHECK_FUNCS(mblen)
AC_CHECK_FUNCS(memalign)
AC_CHECK_FUNCS(memrchr)