summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-01-09 11:49:23 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-01-09 11:49:23 +0000
commitb5faf430ccb6e25492398d13b2f62ec67e264e4a (patch)
treeb4db4edaa4d7cffe037580310290a10acc95d002 /configure.in
parent40967a5c0b975f3f3ec1538a820985aa61b65b8f (diff)
configure.in: -mstackrealign
* configure.in: -mstackrealign is necessary for -msse2 working. [ruby-core:54716] [Bug #8349] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@44539 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 9c95cc4d8a..dae346b20e 100644
--- a/configure.in
+++ b/configure.in
@@ -862,7 +862,10 @@ if test "$GCC" = yes; then
# doesn't seem necessary on Mac OS X
],
[i[4-6]86], [
- RUBY_TRY_CFLAGS(-msse2 -mfpmath=sse, [RUBY_APPEND_OPTION(XCFLAGS, -msse2 -mfpmath=sse)])
+ RUBY_TRY_CFLAGS(-msse2 -mfpmath=sse, [
+ RUBY_APPEND_OPTION(XCFLAGS, -msse2 -mfpmath=sse)
+ RUBY_TRY_CFLAGS(-mstackrealign, [RUBY_APPEND_OPTION(XCFLAGS, -mstackrealign)])
+ ])
]
)
fi