summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorkosaki <kosaki@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-11-24 23:06:26 +0000
committerkosaki <kosaki@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-11-24 23:06:26 +0000
commitb2eae7891b8a808f7f737833fbaf84b0d467377c (patch)
tree027777aed1f42f3b072f1883b26cf3a566367696 /configure.in
parentd0e615e25f839d32507bcccb593d5fc3c28db28c (diff)
* configure.in: add -fstack-protector. It help to protect us from
stack smashing attack. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@33836 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 827bece224..caef7d6684 100644
--- a/configure.in
+++ b/configure.in
@@ -497,6 +497,7 @@ if test "$GCC:${warnflags+set}:no" = yes::no; then
fi
if test "$GCC" = yes; then
RUBY_TRY_CFLAGS(-D_FORTIFY_SOURCE=2, [RUBY_APPEND_OPTION(XCFLAGS, -D_FORTIFY_SOURCE=2)])
+ RUBY_TRY_CFLAGS(-fstack-protector, [RUBY_APPEND_OPTION(XCFLAGS, -fstack-protector)])
fi
if test "$GCC" = ""; then